Results 1 to 3 of 3

Thread: Get Rid of the Ellipsis Glitch (For Rio)

Hybrid View

  1. #1
    Super Senior Member Delphinus's Avatar
    Join Date
    Dec 2010
    Posts
    2,337

    Get Rid of the Ellipsis Glitch (For Rio)

    Whenever you click on the title of a thread that uses three ellipsis in its title, the server cocks up. However, it's not necessary to show the thread title as part of the linked url for a topic to work.

    It uses this form atm

    showtopic.php?[thread_id][thread_name]/page[page_number]

    All you need to do is get rid of the piece of code that inserts the [thread_name] variable into the url, making it

    showtopic.php?[thread_id]/page[page_number]

    and it should work in exactly the same way, but without the ellipsis problem. Simple fix, big problem solved.
    Quote Originally Posted by Fenn
    You forgot your F in Modesty.

  2. #2
    Super Senior Member Delphinus's Avatar
    Join Date
    Dec 2010
    Posts
    2,337
    New suggestion: if keeping the name in the URL is essential for some reason, it's probably a good idea to strip characters that have a meaning in the context of internet addresses out of the title before inserting that title into the URL.
    Quote Originally Posted by Fenn
    You forgot your F in Modesty.

  3. #3
    Your Friendly Ban Hammer-er Rio's Avatar
    Join Date
    Oct 2010
    Location
    USA
    Posts
    2,732
    Thanks for the suggestion! I'll have a look and see if it can get done.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •